Recent Posts

Pages: [1] 2 3 ... 10
1
CiviVolunteer / Re: New Volunteer Project - Blank Page
« Last post by TwoMice on July 21, 2017, 09:28:11 am »
For those who may not realize it:

CiviCRM 4.7.21 was a security release (https://civicrm.org/blog/jamienovick/security-release-civicrm-4721-and-4629). Rolling back to earlier versions is not to be done lightly.
2
CiviVolunteer / Re: New Volunteer Project - Blank Page
« Last post by GinkgoFJG on July 20, 2017, 02:14:37 pm »
The change was introduced in 4.7.21, so anything before that should work. If you'd like to continue the conversation about funding a fix, please email inquire@ginkgostreet.com. Thanks!
3
CiviVolunteer / Re: New Volunteer Project - Blank Page
« Last post by DavidO on July 20, 2017, 02:04:29 pm »
You've provided an incredible product; I'm grateful for your work and will continue to contribute money to this project.

In the mean time, how far back to I need to roll my installation of CiviCRM to regain this functionality (the ability to create projects and track volunteer time)?

Again, thank you.
4
CiviVolunteer / Re: New Volunteer Project - Blank Page
« Last post by GinkgoFJG on July 20, 2017, 06:42:25 am »
CiviCRM 4.7.21 introduced some changes in how CiviCRM works with Angular (as well as updates to the Angular library itself). CiviVolunteer needs to "catch up" to the changes made in core.

I'd like to correct this problem as soon as possible but I'm not sure when my schedule will allow me to get to unfunded work.
5
CiviVolunteer / Re: New Volunteer Project - Blank Page
« Last post by DavidO on July 19, 2017, 09:59:01 pm »
I also get a blank screen after trying to start a new volunteer project or setting up volunteers within an event.

I'm using CiviCRM 4.7.21 and CiviVolunteer 4.6-2.2.1

Below is the error code when I do so.

Many thanks for any advice.

==========================================

angular.js:38 Uncaught Error: [$injector:modulerr] http://errors.angularjs.org/1.5.11/$injector/modulerr?p0=crmApp&p1=Error%3A…Fcivicrm%2Fbower_components%2Fangular%2Fangular.min.js%3Fotdh60%3A21%3A332)
    at angular.js:38
    at angular.js:4692
    at q (angular.js:325)
    at g (angular.js:4653)
    at fb (angular.js:4575)
    at c (angular.js:1809)
    at Gc (angular.js:1830)
    at se (angular.js:1715)
    at HTMLDocument.<anonymous> (angular.js:32616)
    at i (jquery.min.js?otdh60:2)
(anonymous) @ angular.js:38
(anonymous) @ angular.js:4692
q @ angular.js:325
g @ angular.js:4653
fb @ angular.js:4575
c @ angular.js:1809
Gc @ angular.js:1830
se @ angular.js:1715
(anonymous) @ angular.js:32616
i @ jquery.min.js?otdh60:2
fireWith @ jquery.min.js?otdh60:2
ready @ jquery.min.js?otdh60:2
K @ jquery.min.js?otdh60:2
6
NOTE: This issue has been fixed as of CiviCRM 4.7.22 (and CiviCRM 4.6.30 for the Long Term Support version). Please upgrade or see info below on how to fix manually.

This issue occurs when using CiviSMTP service from any CMS running CiviCRM 4.7.21 or CiviCRM 4.6.29.

The following error occurs when sending an email:

Code: [Select]
Fatal error: Call to a member function enableCrypto() on null in <path_to_drupal>/sites/all/modules/civicrm/vendor/pear/net_smtp/Net/SMTP.php on line 615
To fix this please do the following:

- Revert any custom changes made to <path_to_civicrm_module>/vendor/pear/net_smtp/Net/SMTP.php file, if any.

- Edit the same SMTP.php file and make the following change:

Replace line 615 that currently looks like this:

Code: [Select]
if (PEAR::isError($result = $this->socket->enableCrypto(true, $crypto_method))) {
with the following line:

Code: [Select]
if (PEAR::isError($result = $this->_socket->enableCrypto(true, $crypto_method))) {
(the difference is the added underscore in $this->_socket)

Then please try sending an email from the Outbound Email Settings and if that works, please try sending a bulk mailing from CiviMail to confirm that this issue has been fixed.

Email us at support@civismtp.com if you have any questions.
7
This issue has been fixed as of CiviCRM 4.7.22.

Email us at support@civismtp.com if you have any questions.
8
In the ar_EG translation of civicrm the months are not used in my contry, and i need to change the labels of some months.
I use drupal-civicrm 4.7.18 (drupal 7.54).

Thnks for help
9
These forums are deprecated. You can post here http://civicrm.stackexchange.com/ and you will get a response.
10

These forums are deprecated. You can post here http://civicrm.stackexchange.com/ and you will get a response.
Pages: [1] 2 3 ... 10